October 23, 2018, 06:51:08 PMLatest Member: Bazard90

Author Topic: No Training Room at own Level  (Read 1688 times)

0 Members and 1 Guest are viewing this topic.

micha140182

  • Registered member
  • *
  • Posts: 1
    • View Profile
No Training Room at own Level
« on: November 30, 2014, 11:34:28 AM »
Hey there,

it´s my first posting here an my english isn´t the best, but i will give my best.

I created a new map and a new level. Both works good, but i can´t buid a training room. It´s checked in the level editor so i don´z know why i cant´t build it. Hope someone knows the answer.

Thanks for reading.


Edit: I can build it, but not from the beginning. Is there a way to change it?
« Last Edit: November 30, 2014, 12:23:20 PM by micha140182 »

snowblind

  • Registered member
  • *
  • Posts: 67
    • View Profile
Re: No Training Room at own Level
« Reply #1 on: December 29, 2014, 02:01:56 PM »
I can confirm that there is something wrong here. It will be available, but not from the start. If you use the All Research Cheat, you will see it. Normal research will unlock it as well. I will add the missing option to the editor.

If you want a quickfix, you can open your level in a simple text editor.
Search for this table:

---------------------- Objects -------------------------
| Objects available | Available from the start | Strength | Available for this level | Comment

and then this line:
#objects[37].StartAvail.StartStrength.AvailableForLevel.RschReqd 0 10 1 20000

then simply change the first 0 to a 1:

#objects[37].StartAvail.StartStrength.AvailableForLevel.RschReqd 1 10 1 20000